Mar
16

VMware View privilege escalation and cross-site scripting – Security Advisory

Yesterday VMware released a patch yesterday that affects View 4.6 and lower. View 4.0 is affected but will not being getting patch. Yet another reason to upgrade.

VMware Security Advisory

Advisory ID: VMSA-2012-0004
Synopsis: VMware View privilege escalation and cross-site scripting
Issue date: 2012-03-15
Updated on: 2012-03-15 (initial advisory)
CVE numbers: CVE-2012-1508, CVE-2012-1509, CVE-2012-1510, CVE-2012-1511
———————————————————————–

1. Summary

VMware View addresses privilege escalation and cross-site scripting
issues.

2. Relevant releases

View 4.6.0 and older.

3. Problem Description

a. VMware Virtual Desktop Display Driver Privilege Escalation

The VMware XPDM and WDDM display drivers contain buffer overflow
vulnerabilities and the XPDM display driver does not properly check
for NULL pointers. Exploitation of these issues may lead to local
privilege escalation on View virtual desktops.

VMware would like to thank Tarjei Mandt for reporting theses issues
to us.

The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the names CVE-2012-1509 (XPDM buffer overrun),
CVE-2012-1510 (WDDM buffer overrun) and CVE-2012-1508 (XPDM null
pointer dereference) to these issues.

Column 4 of the following table lists the action required to
remediate the vulnerability in each release, if a solution is
available.

VMware Product Running Replace with/
Product * Version on Apply Patch **
============= ======== ======= =================
View 5.0 Windows not affected
View 4.6 Windows View 4.6.1
View 4.0 Windows affected, no patch planned

* Other affected products are documented in VMSA-2012-0005; this
advisory is exclusively for View.

** Notes on updating VMware Virtual Agents:

In order to remediate the problem, VMware View Agents must be
updated in any pre-existing virtual desktops. The XPDM and WDDM
drivers are part of the View Agent.

View Agents that have moved to View 5.0 from a lower View version
are affected if their View Agent was not updated after the move.

b. View Manager Portal Cross-site Scripting

A cross-site scripting vulnerability in View Manager Portal may
allow a remote attacker to run scripts in the victim’s browser. The
attacker can trigger this vulnerability by supplying a crafted URL
to the victim and convincing them to click on the link.

Column 4 of the following table lists the action required to
remediate the vulnerability in each release, if a solution is
available.

VMware Product Running Replace with/
Product Version on Apply Patch
============= ======== ======= =================
View 5.0 Windows not affected
View 4.6 Windows View 4.6.1
View 4.0 Windows affected, no patch planned

4. Solution

Please review the patch/release notes for your product and
version and verify the checksum of your downloaded file.

View 4.6.1
———-
http://downloads.vmware.com/d/info/desktop_downloads/vmware_view/4_6

Release Notes
https://www.vmware.com/support/view46/doc/view-461-release-notes.html

Speak Your Mind

*